Failed to initialise crypto/ssl libraries after upgrade process

Document ID : KB000050580
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

After performing an upgrading from CA Directory r12.0 SP1 to r12.0 SP5, the DSAs fail to start showing error: 'Failed to initialise crypto/ssl libraries'

Solution:

The reason is due to somehow not able to execute the CAPKI setup during the initial upgrade which completed successfully.

Change directory to where the CAPKI software is located (usually next to the eTrust Directory) and run the following commands:

chmod +x setup
./setup install caller=ETRDIR env=all verbose

After successfully extracting and running CAPKI install, you should be able to start the DSAs successfully and not see the above mentioned error.