Expected vApp patch results not seen

Document ID : KB000009296
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

CP-VA-140100-004 is a cumulative patch and so it should include the fixes from CP-VA-140100-002. One of the fixes we need is F20715/US382208 in CP-VA-140100-002, Support for Wildfly HTTPS listener and SSL certificates for IDM, IP and IG. The release notes for this fix indicate "For existing IG and IP nodes: you must manually run the "repair_service" command." We ran the repair_service command, but our standalone.xml file is still not updated per F20715/US382208 in CP-VA-140100-002. Also, we have noticed a discrepancy between the vApp admin console "help" link that shows Identity Governance at release 14.1.0 GA (no patch level), but we also applied Identity Governance specific patch CP-IGV-140100-0001 to our IG node without error. If we try to reapply IG patch CP-IGV-140100, a message indicates it is already at that patch level. How can we independently verify both of these patches have been applied correctly?

Resolution:

In a Cluster the vApp dashboard can be accessed from any of the 4 nodes in the test environment. Two nodes have just IP installed, and two nodes have just IG installed. The patch information displayed on the Help screen of the vApp dashboard is correct for IG when logged into an IG node, and correct for IP when logged into an IP node. But the version information shown for IG when logged into an IP node shows as GA, when in fact IG is not installed on the IP node. And vice versa for when logged into an IP node. This is misleading, but at least we can now confirm that all four nodes are patched.