Execution status update in Release Manager delayed when Workflow in AE has ENDED_OK

Document ID : KB000087445
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Affects Release version(s): 5;6;7

Error Message :
N/A

Execution is completed in the Automation Engine (AE) as ENDED_OK, but in Release Mangager (RM) the status is displayed as active.  

There are many different reasons that can cause this issue. One main factor is caused by AE's Activities Windows which is related to AE maintenance. Specifically, the more active activities, the slower the AE-RM update.

For each user, the system will get all of the current active RM Workflow executions (ActiveJob contains AE Workflow runid), then trigger a job to retrieve all of the AE Workflow execution statuses back to the RM Workflow execution.  Below is a diagram showing the Workflow.
 
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Environment:
OS Version: N/A
Cause:
Cause type:
Other
Root Cause: The more active activities in AE the slower the AE-Release Manger update.
Resolution:
Update to a fix version listed below or a newer version if available.
 

Fix Status: Released

Fix Version(s):
Release Manager 7.0.1 - Available
Release Manager 6.0.3 - Available
Additional Information:
Workaround :
Clean out all Jobs that have ENDED_OK in the Activity windows in the Automation Engine.  See referenced articles below for necessary queries.

References

Additional relevant articles:

000008807 - Activity Window Cleanup for Automic AE v11.1, v11.2 and v12.0 with Oracle DB  
000008810 - Activity Window Cleanup for Automic AE v11.1, v11.2 and v12.0 with MS-SQL DB