Executing an Autoforecast may cause the WP process to hang.

Document ID : KB000087571
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
N/A

Executing an Autoforecast may cause the WP process to hang in certain situations like in the example below.
 
Settings:
Reduced AUTO_FORECAST_DAYS=7

The following statement doesn’t return a result for XPRESSSIONS hostgroup but XPRESSIONS is used in many jobs within the client.
              
select distinct AHG_HostGroupName from uc4.dbo.AHG;
 
With the setting above, the issue can be reproduced using the following steps:
  1. Activate a Schedule that includes a workflow that the Autoforecast will be forecasting on (JSCH.POLICY).  The workflow in the schedule does not need to be active.  Ensure that the workflow has several layers of jobs and jobp's.
  2. If the schedule is active the Autoforecast hangs when it tries to generate the script.  If the schedule is not active it runs without a problem.
  3. Activate the script object.  Autoforecast is stuck in generating and it can’t be canceled. In order to remove it, manually modify the task.

:print “START: autoforecast request”
:set &autoforecast#=autoforecast()
:print “END: autoforecast request”
:print “Results from autoforecast (0 = successful): &autoforecast#”
:if &autoforecast# = 0
:print “We are OK”
:else
:print “We are stuck!”
:exit 1
:endif

Cause:
Cause type:
Defect
Root Cause: Refer to description
Resolution:
This field was added on 30/03/2017. This article has not been updated yet. Refer to the "Description" or "Workaround" sections for solution information.

Fix Status: Released

Fix Version(s):
Automation Engine 11.2.2 - Already released.
Automation Engine 11.1.3 - Already released.
Automation Engine 10.0.8 - Already released.
Additional Information:
Workaround :
N/A