Excessive Archive Logs Slow Performance

Document ID : KB000006764
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

The Release Automation environment's performance slows dramatically due to a large volume of archive logs being written to the database.

Cause:

Version 4.7.1 introduced the periodic purging of health check records that generate two queries:

 

update health_round_samples_aud set REV = :1 where REV < :2

update health_sample_aud set REV = :1 where REV < :2

 

If the queries for this check run too often, it can impact performance.

Resolution:

(1) Launch Automation Studio.

(2) Navigate to the Administration tab.

(3) Click System Settings.

(4) Set the value for "Monitoring data: clean every (in minutes)" to "720".

(5) Restart the NAC.

Additional Information:

Per the 6.2 product documentation (found here: https://docops.ca.com/ca-release-automation/6-2/en/dashboard-and-reporting/manage-and-view-the-health-monitor):

Important!  From version 6.3 and above, the Health Monitor function is no longer available. To monitor agents and servers, use an application performance management tool.