Evaluation of Deployment Target not possible even with required permissions

Document ID : KB000087469
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Affects Release version(s): 7

Error Message :
N/A

In the Evaluation Settings even if all the required permissions have been granted to a user to see the Deployment Target, the user is not able to select it to evaluate it in the Action PromptSet.

This works flawlessly if we are logged in as Administrator.

Investigation

  • Using the wizard create all required objects. These objects belongs to the same folder and are created with all assignments to deploy a Workflow with the objects.
  • Login to system with a non-admin user who has full permissions on the folder (Read, Write, Execute, Use, Delete) and all custom types
  • Go to the Dynamic Properties screen of the component, open the Change Setting popup​
Observation: The Targets which the user has permissions for are shown in a drop down box.
0EMb0000001QXz1.png
  • Open design Workflow >> Component Flow in Process Assembly tab >> Select an Action.
  • In the PromptSet sheet of the Action, open the Change Settings dialog
Results

Actual:  No Deployment Target is shown in the dropdown list
0EMb0000001QXz6.png

Expected:  All Deployment Targets which a user had READ permissions on should be displayed.

 

Environment:
OS: Windows Server 2012
OS Version: N/A
Cause:
Cause type:
Defect
Root Cause: The permission filter was not defined correct. The issue did happen if the user was not administrator.
Resolution:
Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Release Manager 7.0.1 - Available
Release Automation 7.0.0 HF1 - Available
Additional Information:
Workaround :
N/A