Errors while verifying Service Repository in Datamaker

Document ID : KB000005439
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

When trying to connect to a profile in Datamaker, I am receiving the following error messages: 


Service Layer: Error Testing Connection 
Error verifying Service Repository: 
Mismatched DB versions (This = 3.2D, Service= 3.2B) 
Mismatched Service Names (This = PTESTSQL01, Service= DEV-TEST03\TEST) 
Mismatched Schemas (This = gtrep_testing, Service= gtrep) 


We recently copied over our repository to a new location in another server. We updated the rep.xml file with the new server information. We tried updating the repository (ctrl+alt+m), but there was nothing to update or sync. Datamaker seems to be referencing both database names still. 

Environment:
CA Test Data Manager (TDM)- Datamaker
Cause:

The error is occuring due to the differences between the local repository version (3.2D) and the remote repository version (3.2B) as seen in the service layer. 

Resolution:

To resolve this, update your 'Primary Service URL' from the Security-> Users and Group-> Service Layer tab to reflect the correct machine name.

primary service url.png

Additional Information:

If you experience any further issues, please open a support case by going to https://www.ca.com/us/services-support/ca-support/contact-support.html.