Errors when running install_gems.rb

Document ID : KB000098740
Last Modified Date : 31/05/2018
Show Technical Document Details
Issue:
When launching install_gems.rb to install a connector, several errors as shown below are displayed
./install_gems.rb: line 2: BASE_GEMS: command not found
./install_gems.rb: line 3: syntax error near unexpected token `('
./install_gems.rb: line 3: `CORE_GEMS = %w(rally_api rallyeif-wrk)'

 
Environment:
Linux
Mac
Cause:
The script requires that Ruby 2.2 be installed.   Additionally, the script does not contain the location to an interpreter as the first line, therefore it needs to be called as a parameter of the ruby command. 
Resolution:
To launch the script successfully, run the following command:
# ruby install_gems.rb