Errors When Attempting to Edit the External user Store in EEM

Document ID : KB000032005
Last Modified Date : 14/02/2018
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Root Cause:

This is caused by an invalid entry in your 'server.xml' file, pertaining to the Userstores section. 

The naming convention of the <genericldapstore> can NOT contain a backslash. 

The server.xml file cannot parse the backslash. 

 

Resolution:

To resolve this condition modify your <genericldapstore> entry to remove the backslash, via the following steps:

Stop the iGateway process

In the server’xml file, change your <genericldapstore> entry like the example below.

 

Example:

From

<genericldapstore name=”my\ldap”>

To

<genericldapstore name=”myldap”>

Start the iGateway process.

 

You will now be able to edit the External User Store in EEM.