Error with PermGen space

Document ID : KB000008130
Last Modified Date : 14/02/2018
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Issue:

The DE Scheduling Manager abnormally terminates due to the error "[ERROR] SS: [cybermation.schedulerserver.CybSchedulerServerApplicationRegistry] The thread SS collapsed. The exception is: java.lang.OutOfMemoryError: PermGen space"

Environment:
Windows serversAny databaseAny release of CA Workload Automation DE
Cause:

This issue is caused by exceeding the maximum java heap memory allocation defined in the windows.service.properties file on Windows servers.

Resolution:

You should always ensure that you have adequate available resources before making any changes to the configuration. Consult with your System Administrator if necessary!

You can increase the value of the jvmproperty_11=-XX:MaxPermSize parameter within the windows.service.properties located in your DE installation path. The default value is 512m. Provided you have adequate resources available, you can increase this value to 1024m. 

Default: jvmproperty_11=-XX:MaxPermSize=512m

New value: jvmproperty_11=-XX:MaxPermSize=1024m