Error while flushing messages (unable to mark as read)

Document ID : KB000120658
Last Modified Date : 09/11/2018
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Issue:
We have an alarm with a very high supression count >4,000,000 from a single robot
the alarm is from the spooler probe
Error while flushing messages (unable to mark as read)
Cause:
Usually we will see this on a robot for one of the following reasons 
  1. There is AV software scanning the nimsoft directory preventing the spooler service from functioning correctly 
  2. There is no hard drive space on the robot volume 
  3. The robot does not have proper permissions. 
  4. There are two spooler services running 
  5. There is a file system problem on the system where the robot is installed. 
The most common reason is AV software scanning the nimsoft directory
Resolution:
  • Add the nimsoft folder to the exclusions for the AV software.
  • If this does not resolve the issue check for and resolve the remaining issues as listed above