Error when trying to load rapid automation solution

Document ID : KB000090031
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error when trying to load rapid automation solution
Resolution:

Symptoms

  • Error when trying to load jar file to upgrade rapid automation solution


Investigation

Data needed for analysis:

  • Logfile of the load Utility (Default location Utility/temp folder)

The following information can be found in the load utility logfile:

U0038247 Minor Version of the database ('056') is higher than the Minor Version of the program ('040'). Can't continue.


Cause

The error message "U0038247 Minor Version of the database ('056') is higher than the Minor Version of the program ('040'). Can't continue." states
that the file you are trying to load is from a different version than the load utility you have in use.

Before Serviepack 4 the following components need to be out of the same service pack:

  • Automation Engine
  • Initial Data
  • Userinterface
  • Callapi
  • Utility

For example:

Trying to load a service pack 4 rapid automation solution with a load utility version out of service pack 2 is not possible.
The Utility first has to be upgraded to a servicepack 4 version, before loading the rapid automation solution out of service pack 4


Resolution

  • Upgrade the Utility to the same version as the Initial data that you are trying to load.
  • Restart the load Utility and load rapid automation solution jar file.