Error when creating endpoint

Document ID : KB000005277
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

When creating an endpoint or during the usage of accounts on the endpoint, you run into issues checking-in/out accounts or changing passwords for accounts. You will receive cryptic messages such as below which do not fully explain why the EP is having issues.

 

eTDYNDirectoryName=HOSTNAME,eTNamespaceName=SSH Device,dc=im,dc=etasa: nN7rLb*C";eTDYNHost not found in attribute registry!
 

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><Error><description>Endpoint cannot be created in this endpoint type. Details: Unknown error
Native error: code 17 (UNDEFINED_ATTRIBUTE_TYPE): failed to add entry eTDYNDirectoryName=HOSTNAME,eTNamespaceName=SSH Device,dc=im,dc=etasa: nN7rLb*C&quot;;eTDYNHost not found in attribute registry!</description></Error>
Updating configuration for HOSTNAME
<?xml version="1.0" encoding="UTF-8" standalone="yes"?><Error><description>Endpoint not found: HOSTNAME</description></Error>

Cause:

The errors received are not quite indicative of the issue, however, the issue resides in the password of the Endpoint administrator account being used during the registration. There most likely is a special character in the password that PIM does not accept or understand how to use in most cases is related to ';'.

Resolution:

By correcting the password to be more 'simple' and utilizing widely accepted characters (i.e. a-z,A-Z,0-9,!,@,#) and re-registering the endpoint, it should register correctly.