Error when applying Cumulative patch for Service Desk Manager 14.1

Document ID : KB000005679
Last Modified Date : 23/03/2018
Show Technical Document Details
Issue:

When trying to apply a Service Desk Manager 14.1 cumulative patch (i.3. 14.1.03 or 14.1.04), you may receive the following error

"Unable to execute CA SDM Binary Patch. See logs for more details"

User-added image

Environment:
CA Service Desk Manager 14.1
All Supported Windows Operating Systems
Cause:

The SETUP.EXE program is known to have issues when executed from a location with a very long path name.

Resolution:

The easiest way to resolve this issue is to copy the SETUP.EXE to the root of a drive on the CA SDM server (i.e. C:\) and execute it from there.

Alternatively, you can place the entire cumulative patch install folder structure to a directory with a shorter path (i.e. C:\CUMPatch).