Error upgrading JasperReports Server from 6.2.0 to 6.3.0

Document ID : KB000107035
Last Modified Date : 18/07/2018
Show Technical Document Details
Issue:
Error message when upgrading JasperReports Server from 6.2.0 to 6.3.0:

install.bat -r sample_sql.properties

"Found JAVA_HOME environment variable" 
"Found both java.exe and javaw.exe in JAVA_HOME's bin directory" 
"Validation of JAVA_HOME is done" 
"Validation of argument count is done" 
"ANT_ARGS are -Dproperties.file=sample_sql.properties -Dlog.file=install.log" 
"Starting build.xml with ANT_ARGS -Dproperties.file=sample_sql.properties -Dlog.file=install.log" 
Buildfile: c:\jasperserver63\ca_install\build.xml 

BUILD FAILED 
c:\jasperserver63\ca_install\build.xml:2: The following error occurred while executing this line: 
c:\jasperserver63\ca_install\create_master.xml:2: java.lang.UnsupportedClassVersionError: com/ca/bicoe/cajasperserver/install/preinstall/utils/Decryption Task : Unsupported major.minor version 52.0 
Environment:
JasperReports Server 6.3.0
Cause:
Unsupported major.minor version 52.0 comes when you are trying to run a class compiled using Java 1.8 compiler into a lower JRE version e.g. JRE 1.7 or JRE 1.6.
Resolution:
The simplest way to fix this error is install the latest Java release i.e. Java 8 and run JasperReports Server installer again.