Error "Unable to access job" trying to restart a CA WA ESP failed job

Document ID : KB000005227
Last Modified Date : 14/02/2018
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Issue:

When trying to restart a failed job using CA WA Restart EE from the CA WA ESP CSF (Consolidated Status Facility) panel , error message "Unable to access job" is issued.  PF1 produces message "Job is being restarted by another user". 

Environment:
- CA Workload Automation ESP Edition- CA Workload Automation Restart EE (aka Encore)- CA ESP Workload Automation Workstation Option
Cause:

The failed job is locked by an ESP Workstation user.  This lock occurs when the ESP Workstation user right-clicks on the failed job, selects option "Restart using Restart Option EE", and stays on the Restart option panel without taking any action.

Resolution:

1. Execute the following pagemode commands to determine who locked the job, and to obtain the lock token id: 

INFOMSG SET 

ENCREQ LISTLOCK 

2. Sample display from the above commands: 

ESP4447I TOKEN(1013720170110163125#13) ENCREQ JOBNAME(JOB1) APPLICATION(PAYROLL) GENERATION(2) QNAME(ESPCSF) RNAME(C'JOB1          PAYROLL',X'00000002') SCOPE(SYSTEMS) CTLTYPE(E) REQTYPE(USE) USER(CYBERUSR) LOCKED(20170110-164720) ....

ESP4449I ENQ'S displayed: 1 

3.  Execute the following command to remove the lock using the lock token id returned from the Encreq Listlock command: 

ENCREQ UNDOLOCK TOKEN(1013720170110163125#13)

Additional Information:

https:/docops.ca.com/esp and look for "ENCREQ LISTLOCK".