Error thrown in Policy Manager: "Cannot start Service Debugger. There is a Service Debugger already running for the service/policy."

Document ID : KB000098243
Last Modified Date : 28/05/2018
Show Technical Document Details
Issue:
  • Trying to open a Service Debugger session in Policy Manager and receive the following error: "Cannot start Service Debugger. There is a Service Debugger already running for the service/policy."
Environment:
  • All versions of the CA API Gateway which contain the Service/Policy Debugger feature.
Cause:
  • This is often caused by unexpected disconnections between Policy Manager and the Gateway. When logging back in to Policy Manager and trying to open a new Debugger window to the same service, the error can be thrown.
    • The unexpected disconnections are usually the result of an issue with the NIC on the workstation running Policy Manager or a brief network outage.
Resolution:
  • There is a cleanup task that runs in the CA API Gateway ("Gateway") which runs periodically to remove Debugger sessions that have been inactive for a certain amount of time.
    • By default, the cleanup task runs every 24 hours plus 1 minute, terminating sessions that have been inactive for 24 hours.
  • The values for how often the cleanup task runs is configurable in the system.properties (/opt/SecureSpan/Gateway/node/default/etc/conf/system.properties) file on the Gateway, with the values being in milliseconds. This process is documented with the below two system properties:
    • com.l7tech.server.stepdebug.inactiveSessionCleanIntervalMillis
    • com.l7tech.server.stepdebug.inactiveSessionTimeoutMillis