Error: "There was a problem connecting to the server. Refresh the page and try again. Please contact the system administrator if the problem persists." When Loading xFlow Interface

Document ID : KB000044405
Last Modified Date : 14/02/2018
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Issue: 

Error in CA xFlow Analyst Interface:

There was a problem connecting to the server. Refresh the page and try again. Please contact the system administrator if the problem persists.

Error in Developer Tool in Chrome:

Failed to load resource: net::ERR_NAME_NOT_RESOLVED http://hostname:9004/initialContext

Environment:  

Service Desk Manager 14.1 Cum 3 - CA xFlow Analyst Interface

Cause: 

The configuration set in the Configuration files (casm.conf.js   and casm.conf.do-not-change.js) is not correct.

Resolution:

1) Go to the xFlow Server (s)

2) Go to xFlow_home\Apps\UI\Apache24\htdocs\conf Example: C:\Program Files\CA\xFlow\APPS\UI\Apache24\htdocs\conf

3) Open with notepad or similar the casm.conf.js file   and casm.conf.do-not-change.js

4) Set the right server URL for all services, specially the one for api.

Example:

api : {
            server : 'http://hostname:9004'
        },

5) Restart xFlow Service

Additional Information:

Modify the configuration file:

https://docops.ca.com/ca-service-management/14-1/en/implementing/implementing-ca-service-management-14-1-03/authenticate-the-xflow-analyst-user-interface-users/enable-secure-socket-layer-ssl#EnableSecureSocketLayer(SSL)-ModifytheConfigurationfile