Error "The CA directory - itechpoz service on Local Computer started and then stopped" When Starting CA Directory - itechpoz

Document ID : KB000077079
Last Modified Date : 05/06/2018
Show Technical Document Details
Issue:
Cannot start CA Directory - itechpoz.

The following error appears in the CA\Directory\dxserver\itechpoz_trace.log

? [156] 20180403.223302.551 ERROR : Syntax Error: Line 1 in CA\Directory\dxserver\config\knowledge\itechpoz.dxc near '509'
Invalid address hostname.domain.com
* [156] 20180403.223302.758 DSA_E1280 Error in initialization files
* [156] 20180403.223302.758 DSA_I1240 DSA shutting down
Environment:
EEM 12.x
Cause:
The domain has changed in the server where EEM is installed.
 
Resolution:
1. Go CA\Directory\dxserver\config\knowledge\itechpoz.dxc

Search for dsa-name (line 7) and update with it the new domain. Example: dsa-name     = <cn iTechPoz><cn PozDsa><cn "hosntame.newdomain">
Search for address (line 10) and update with the new domain. Example: address      = ipv4 "hosntame.newdomain" port 509

2. Go to CA\SC\EmbeddedEntitlementsManager\config\server\server.xml

Search and modify all 3 items below with the new domain:

<hosts primary="hostname.newdomain">
<host id="hostname.newdomain">
<dsaurl>hostname.newdomain:509</dsaurl>

3. Go to CA\SC\iTechnology\iPoz.conf

Search and update the domain in the hostid tag, it should look like:

<HostId>hostname.newdomain</HostId>

4. Save Changes

5. Start Service