Error SRM has not finished starting

Document ID : KB000125422
Last Modified Date : 29/01/2019
Show Technical Document Details
Issue:
Get an error "SRM has not finished starting" when trying to launch report manager. You will see the below errors in the One click Tomcat logs:

(SRM/Startup/Container) (com.aprisma.spectrum.app.repmgr.web.servlet.SRMBootstrapServlet) - (ERROR) - Error occurred while initializing SRM components
org.springframework.dao.DuplicateKeyException: PreparedStatementCallback; SQL [INSERT INTO wkpeventfilemap (file_id, type) VALUES (?, ?)]; Duplicate entry '13-65555' for key 'file_id'; nested exception is java.sql.BatchUpdateException: Duplicate entry '13-65555' for key 'file_id'
    at org.springframework.jdbc.support.SQLErrorCodeSQLExceptionTranslator.doTranslate(SQLErrorCodeSQLExceptionTranslator.java:239)

 
Environment:
Spectrum 10.x
Cause:

This happens when there is a problem in any of the event filter XML files under custom directory of OneClick. The files are located in the below location

"<Specroot>\custom\repmgr\config\events"

Below is a brief description about the wkpeventfiles table:

This table lists all the event filter XML files that are read from custom directory in OneClick.

Event filters are uniquely named sets of any number of predefined event codes. When users configure an event report, they can elect to specify in the Select the Event Types to include or exclude a field whether to include or exclude data in the report from events in a particular event filter.

An event filter is defined by an XML file that specifies the event codes. Users can create new event filter files, and they can copy and modify the event filter files included with Report Manager. This file resides in custom directory of OneClick.

Report manager reads the event filter XML files from custom directory of OneClick. Once read, the data from each XML file is added to two tables: wkpeventfiles and wkpeventfilemap.

Table wkpeventfiles lists all the XML files that were read from the custom directory.

Resolution:
Find out the XML file under "<Specroot>\custom\repmgr\config\events" which is causing the problem and rename it or move it to another location. Restart the Tomcat service and that should fix the problem.

Whenever Tomcat service is started, Report manager reads the event filter XML files from custom directory of OneClick. Once read, the data from each XML file is added to two tables: wkpeventfiles and wkpeventfilemap.
Additional Information:
https://docops.ca.com/ca-spectrum/10-3-0/en/managing-client-applications/report-manager/report-manager-db-schema/reporting-database#id-'reporting'Database-wkpeventfilemap