Error snmpcollector is busy PPM-023

Document ID : KB000045520
Last Modified Date : 17/08/2018
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Issue:

When loading snmpcollector configuration in Admin Console the following error is generated:

Message: Request Error: Probe snmpcollector on robot  /domain/hubname/robotname is busy. 
Resolution: Please wait and retry loading configuration later. 
Error Code: PPM-023 

Message: An internal server error has occured. 
Resolution: See log for details. 
Error Code: MONS-002. 

Environment:
snmp collector probe version:- 2.26 

UIM version:- 8.4
Cause:
Not enough memory allocated or available to snmpcollector
Resolution:
1. Backup the snmpcollector.cfg file
2. Open the snmpcollector.cfg in a text editor, like notepad. In the .cfg file it shows this:
<startup>
options = -Xms64m -Xmx1024m -XX:+UseConcMarkSweepGC -XX:StringTableSize=10003 -Duser.language=en -Duser.country=US </startup>

3. Change this: "-Xmx1024m"   to this: "-Xmx2048m"
4. Save the snmpcollector.cfg and restart the snmpcollector probe
5. If that still fails try "-Xmx4096m"

6. Make sure that the snmpcollector robot hub machine DOES have enough physical memory available to accommodate the allocation change.