Error returned after running CA Performance Management (CAPM) Top N report in CABI Jaspersoft r6.3

Document ID : KB000009044
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Observing an error while running a TopN report in CA Business Intelligence (CABI) Jaspersoft instance integrated with CA Performance Management (CAPM).

 

2017-12-19 14:25:29,610 ERROR JRQueryExecuterAdapter,http-apr-8080-exec-9:154 - Error while executing query net.sf.jasperreports.engine.JRException: net.sf.jasperreports.engine.JRException: com.fasterxml.jackson.core.JsonParseException: Unexpected character ('<' (code 60)): expected a valid value (number, String, array, object, 'true', 'false' or 'null')

at [Source: java.io.ByteArrayInputStream@740949c0; line: 1, column: 2] 

Environment:
All supported CA Performance Management & CA BI Jaspersoft integrations
Cause:

User logged in running report does not exist in both CAPM and CABI installations

 

Resolution:

According to the CAPM r3.2 documentation:

"Important! Ensure the username and password for each CA Business Intelligence user matches the username and password for each corresponding Performance Center user. LDAP support is planned for a future CA Performance Management release." 

 

Once the user is created in both systems the report runs successfully, the error is resolved.

Additional Information:

https://docops.ca.com/ca-performance-management/3-2/en/integrating/integrate-ca-business-intelligence/install-ca-business-intelligence-reports-and-dashboards#InstallCABusinessIntelligenceReportsandDashboards-ManageUsers