Error received when attempting to activate an inactive CA SDM group/contact: AHD05910:User ID entered needs to be unique.

Document ID : KB000021529
Last Modified Date : 14/02/2018
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Issue

When attempting to activate an inactive CA SDM group or contact, receive the following error:

Error 1 attempting to set delete_flag to "0": AHD05910:System Login entered needs to be unique.Multiple Active Contact records with the specified System Login credentials were found.

Steps to Reproduce

1.  Login to CA SDM GUI

2.  Search for a CA SDM contact or group

3.  On the detail page, click on EDIT

4.  Change the STATUS field from INACTIVE to ACTIVE

Cause

All CA SDM contacts/groups need to have an unique Userid/system login. 

Resolution:

1.  Take a backup of the CA SDM MDB database

2.  Run the following query against the MDB database

select last_name, inactive, contact_type, contact_uuid, userid from ca_contact where contact_type=2308

3.  If the above query returns data, run the following additional query

update ca_contact set userid=NULL where contact_type=2308 and userid=''

4.  Clear web browser cache and attempt to activate the CA SDM contact/group again.