Error openig lic98.err, original code=7317

Document ID : KB000009213
Last Modified Date : 14/02/2018
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Issue:

We are getting a license error message:

I00000001: Initialized CA Harvest SCM Log, Jan 4, 2018 3:06:22 PM.
[Broker License][enterprise-2] <Error opening lic98.err - /opt/CA/SharedComponents/ca_lic/lic98.err, original code=7317>
---------- Begin <Create Package> Process ---------------
---------- End <Create Package> Process ---------------

Environment:
Environment where this message occurred with SCM v13 Incr 2 Server on AIX 7.3, but suspect the same could occur on any Linux/Unix platform.
Cause:

CA Autosys is installed on the same AIX server, and was recently upgraded to the latest version. 

We searched the computer for any file named “lic98.err” and found the file no longer exists. Checking the /opt/CA/SharedComponents/ca_lic folder, we found that this file has now been replaced by a folder called “lic98err”. Inside the folder are error message files in different languages, for example “lic98_EN.err”. We also did not find any file named “ca.olf” in this folder.

We concluded that the upgrade to Autosys might have caused the CA licensing software to be upgraded as well.

Resolution:

We performed the following steps:

  1. Locate or restore the “/opt/CA/SharedComponents/ca_lic/ca.olf” file. If it is missing, restore it. If it is there, adjust ownership and permissions so that the userid that executes the SCM Broker process can read this file.
  2. In folder "/opt/CA/SharedComponents/ca_lic" create a symbolic link so that lic98.err -> /opt/CA/SharedComponents/ca_lic/lic98err/lic98_EN.err

After this the error message stopped and SCM Server functioned normally