Error on upgrading UIM server from 8.5.1 to 9.0.2

Document ID : KB000122872
Last Modified Date : 11/12/2018
Show Technical Document Details
Issue:
When trying to upgrade UIM Server from 8.5.1 to 9.0.2 .
The upgrade stops as shown below. ...
the uimserver_ia_install.log show the following error:
-- -----------------------------------------------------
-- Table `cm_computer_system`
-- -----------------------------------------------------
CREATE TABLE IF NOT EXISTS `cm_computer_system` (
  `cs_id` INT(10) NOT NULL AUTO_INCREMENT ,
  `cs_key` VARCHAR(40) NOT NULL ,
  `cs_type` VARCHAR(1) NOT NULL DEFAULT 'D' ,
  `da_id` INT(10) NULL DEFAULT NULL ,
  `create_time` TIMESTAMP(6) NOT NULL DEFAULT CURRENT_TIMESTAMP(6) ,
  `change_time` TIMESTAMP(6) NULL DEFAULT NULL ,
  `alive_time` TIMESTAMP(6)  NULL DEFAULT NULL ,
..
ENGINE = InnoDB: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '6) ,
  `change_time` TIMESTAMP(6) NULL DEFAULT NULL ,
  `alive_time` TIMESTAMP(6' at line 9


 
Environment:
UIM 8.X -9.02
Centos 7
MySQL 5.5
 
Cause:
MySql 5.5 support was dropped with 8.51 release
 
Resolution:
Upgrade the MySql to a support verison
5.6
5.7