Error occured while installing Service Catalog Patch for 14.1 Cumulative 2 java.lang.ArrayIndexOutOfBoundsException: 0

Document ID : KB000008362
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

The following error appears when installing 14.1 Cumulative 2:

 

ERROR [DeployThread: Applying CA Service Catalog Patch] [SLCMPatch] Error occured while installing Service Catalog Patch
java.lang.ArrayIndexOutOfBoundsException: 0
at com.ca.smsi.installui.patches.SLCMPatch.installSLCMPatch(SLCMPatch.java:137)
at com.ca.smsi.installui.patches.SLCMPatch.installBinaryPatch(SLCMPatch.java:96)
at com.ca.smsi.installui.patches.SLCMPatch.run(SLCMPatch.java:126)
at com.ca.smsi.wizard.task.Task.start(Task.java:222)
at com.ca.smsi.installcore.DeployThread.run(DeployThread.java:281)
2017/10/03 11.34.40.092 DEBUG [DeployThread: Applying CA Service Catalog Patch] [ProgressPage] ProgressPage - Task Changed Applying CA Service Catalog Patch

Environment:
Service Catalog 14.1
Cause:

Upgrading from 14.1 GA to Cumulative is not expected. To upgrade Catalog you need to upgrade to Cumulative 1 and then upgrade to Cumulative 2.

Resolution:

The procedure is different than for SDM/USS because in these applications you can go from 14.1 GA to 14.1 Cumulative 2 but in Catalog you need to install Cum 1 to install Cum 2.

In Service Catalog you need to install Cumulative 1 and then Cumulative 2:

1) For cum 1: Unzip RO80252.CAZ and run the .exe, follow the post installation steps if any.

2) For cum 2: unzip RO86617.CAZ and run the .exe, follow the post installation steps if any.