Error-message when running reports RPT-0020

Document ID : KB000122803
Last Modified Date : 02/04/2019
Show Technical Document Details
Issue:
When running status reports (or other out of the box or custom reports), the following message appears (may be randomly or intermittent). Running the report immediately, see error "RPT-0020 Error occurred while downloading the report <Report Name> Report. Please contact your system administrator error."

When run in scheduled mode, receive an email notification that the report has failed. 

Steps to Reproduce:
  1. In Clarity PPM, go to 'Home' -> 'Reports and Jobs'
  2. Select 'Project Status Detail' report
  3. Fill in the fields > click on 'Submit'
Outcome: Receive RPT-0020 error.

In the app-ca.logs (if report is run in immediate mode) or bg-ca.logs (if report is run in scheduled mode), an error similar to the below appears:

ERROR 2019-03-19 07:01:05,234 niku.njs (clarity:<userID>:nmc.executeAvailReport) Jasper error message:Job: Report name (ID: 9000000000) 
Report unit: /Custom_Reports/Reports/<Report name>

Error Message: The report was not completed. An error occurred while executing it. 
Exceptions: 
com.jaspersoft.jasperserver.api.JSException: Error filling report 
Arguments: 

Caused by: net.sf.jasperreports.governors.MaxPagesGovernorException: Report "<Report Name>l" exceeded the limit of 1,000 maximum pages.
Cause:
This issue is due to the amount of pages in the reports exceeding the allowed limit.  This can happen if he user doesn't choose any project in the parameter (or another parameter value) that will help limit the amount of pages generated. 
 
Resolution:
This is typically do to attempting to run a report with more than the allowed page limit for reports. Run the report setting parameters to reduce the amount of pages below the limit. One way to avoid this issue is to make a parameter mandatory (IE to select just one project rather than all of them).

See the below page limitations:

Jaspersoft Reports:

  • Non-Scheduled (Run in Immediate mode) Reports - 500 page limit
  • Scheduled Reports - 1,000 page limit
For more details see the Page Limits section of the Jaspersoft Reports Server Troubleshooting Tips documentation. 

Export Ad Hoc Views and Reports:
  • Non-Scheduled Reports - 500 page limit
  • Scheduled Reports - 500 page limit
See the below excerpt from: Ad Hoc Views and Custom Report Development. The maximum number of report pages that you can generate is 500 pages for both scheduled and unscheduled reports. The limit applies to all reports and ad-hoc views that are exported using paginated options such as Excel (Paginated) and XLSX (Paginated). The limit is not applicable to the ad-hoc views exported using non-paginated export options such as Excel and XLSX. The following image shows the export options that have a limit to the maximum number of pages that are exported.