Error in Applying CA_API_Gateway_v9.3.00-CR03

Document ID : KB000123025
Last Modified Date : 07/01/2019
Show Technical Document Details
Issue:
While trying to install CA_API_Gateway_v9.3.00-CR03, we received the following error message:

Patch ID CA_API_Gateway_v9.3.00-CR03 (Upgrades the CA API Gateway Software to version 9.3.00-CR03. This patch requires a reboot of the CA API Gateway Appliance after installation.) is ERROR, last modified on 2018-11-26T05:30:28-0800
There were errors during the patch operation. See sspc logs in /opt/SecureSpan/Controller/var/logs for details.


From the sspc logs:
2018-11-26T02:05:46.926-0800 INFO 17 com.l7tech.server.processcontroller.patching.PatchServiceApiImpl: Output from patch install: Test upgrade of /tmp/patchertemp4038074050561534645.tmp/ssg-9.3.00-8670_CR03.noarch.rpm /tmp/patchertemp4038074050561534645.tmp/ssg-appliance-9.3.00-8670_CR03.x86_64.rpm /tmp/patchertemp4038074050561534645.tmp/ssem-1.18.00-6811_CR03.noarch.rpm failed
2018-11-26T02:05:46.930-0800 INFO 17 com.l7tech.server.processcontroller.patching.PatchServiceApiImpl: Output from patch install: Error installing patch: Error executing patch task: non-zero exit code returned from patch install script (returned 1)
2018-11-26T02:05:46.930-0800 INFO 17 com.l7tech.server.processcontroller.patching.PatchServiceApiImpl: Output from patch install: Full stack trace:
2018-11-26T02:05:46.931-0800 INFO 17 com.l7tech.server.processcontroller.patching.PatchServiceApiImpl: Output from patch install: com.l7tech.server.processcontroller.patching.PatchException: Error executing patch task: non-zero exit code returned from patch install script (returned 1)

 
Resolution:
If you have a hotfix applied to your gateway, you will have to "rollback" the hotfix in order to apply the CR03 patch. To remedy this issue, do the following:

1. Take a snapshot/backup of the VM

2. Roll off the hotfix and revert back to the previous version of the gateway using command: rpm -Uvh --old-package <previous_ssg_version-build.noarch.rpm>

3. Apply the CA_API_Gateway_v9.3.00-CR03 patch
./patch.sh upload CA_API_Gateway_v9.3.00-CR03.L7P
./patch.sh install CA_API_Gateway_v9.3.00-CR03
 
Additional Information:
Q: Do I need to apply/reapply previous cumulative releases?
A: No - you can go straight to CR03.

Q: Do I need to reapply the hotfix?
A: It depends. First, check the Resolved Issues for 9.3 CR03 and see if the DEXXXXXX from your hotfix has been included in the cumulative release you are applying.
   If it appears on the list, then you don't need to reapply the hotfix.
   If it does not appear on the list, check the Resolved Issues for 9.3 CR04. If it is included in this CR, apply the CR04 patch in lieu of the CR03 patch.