Error "Could not access HTTP invoker remote service" is occurred during operation in ROC

Document ID : KB000004498
Last Modified Date : 14/02/2018
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Issue:

Following error messages were sometimes occurred when operate deployment plan on Release Operations Center.

And then, deployment plan was failed.

 

  • Error during populating flow descriptor

Cause: Could not access HTTP invoker remote service at [http://<Management Server>:8080/datamanagement/remoting/ExeutionModelService]; nested exception is org.apache.commons.httpclient.HttpExeption: Did not receive successful HTTP response: status = 400, status message = [Bad Request] Cause: Did not receive successful HTTP response: status code = 400, status message = [Bad Request]

  • Error during retrieving workspace components

Cause: Could not access HTTP invoker remote service at [http://<Management Server>:8080/datamanagement/remoting/ActionsInfoManagement]; nested exception is java.io.EOFException

Cause:

Management Server (NAC) was unstable because heap size might be lacked.

Resolution:

Need to increase heap size to be stabilize NAC performance.

Steps:

  1. Open [RA Installation folder]/bin/catalina.bat on NAC using editor.
  2. Modify heap size from 2G to 3G or bigger.
         set JAVA_OPTS=%JAVA_OPTS% -XX:MaxPermSize=256M -Xmx2G
    -> set JAVA_OPTS=%JAVA_OPTS% -XX:MaxPermSize=256M -Xmx3G
  3. Restart Release Automation Server service.