Error: "AHD04013:Internal error in method (got_ldap_domset): LDAP agent not found" In STDLogs When Logging Into SDM Using NTLM or SSO or IIS

Document ID : KB000040628
Last Modified Date : 24/09/2018
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Introduction:
 Symptoms: 
The following error occurs in the stdlgs in Service Desk Manager 14.1 Cumulative 2 once the user is logged in Service Desk Manager:
Date Time ServerName       boplgin              7116 ERROR        bplaccess.c           3337 AHD04013:Internal error in method (got_ldap_domset): LDAP agent not found

Environment:
Service Desk Manager 14.1 Cum 2 configured in IIS with Automatic login
Service Desk Manager 14.1 Cum 2 configured with NTLM
Service Desk Manager 17.0

Cause: 
This is a defect fixed in 14.1 Cum 2 and a variable need to be added to NX.env to avoid the error message. Setting this variable to Yes will strip the Domain name from the login name of the NTLM/IIS authenticated user during Service Desk authentication.

Resolution:
1) Run the following in a command prompt window to add the variable to NX.env:
pdm_options_mgr -c -s STRIP_DOMAIN_NAME -v Yes -a pdm_option.inst

2) Run the following in a command prompt window to add the variable to NX.env template:
pdm_options_mgr -c -s STRIP_DOMAIN_NAME -v Yes -a pdm_option.inst -t

3) Recycle SDM Services for changes to take effect.

4) Clear cache by running: pdm_webcache -H

5) Try to reproduce the issue.

Additional Information:
Fixed Issues in 14.1 Cumulative 2:
https://docops.ca.com/ca-service-management/14-1/en/release-information/what-s-new-in-this-release/ca-service-management-release-14-1-02-enhancements/fixed-issues-14-1-02#FixedIssues-14.1.02-IssuesFixedinCAServiceDeskManager
 
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