ERR_MSG = Unexpected network error  in CA Mobile OTP log

Document ID : KB000101593
Last Modified Date : 10/07/2018
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Issue:
When trying to enroll a new user below data is printed into the CA Mobile OTP log:

/class com.arcot.otp1.network.NetworkCallback( 3274): REQUESTTYPE = provisioning 
I/class com.arcot.otp1.network.NetworkCallback( 3274): ERR_MSG = Unexpected network error 
I/class com.arcot.otp1.network.NetworkCallback( 3274): INTERNAL_ERROR = 
I/class com.arcot.otp1.network.NetworkCallback( 3274): ERR_CODE = 20 
I/class com.arcot.otp1.network.NetworkCallback$3( 3274): erroMsg: Unexpected network error 
Environment:
N/A
Cause:
Below could be the reasons of this issue:

1) There is a communication issue between the CA Mobile/Desktop client machine and the arcotAFM machine. 
2) You are trying to connect to arcotAFM on HTTPS and the CA Mobile OTP or Desktop client machine does not have the root certificate imported into the trusted certificate store of the CA Mobile OTP app or desktop client.
3) The arcotAFM URL you are using is a URL of a load balancer therefore if you are using SSL then you need to import the root certificate of load balancer and import it into the trust store of the CA Mobile OTP or Desktop client machine. 
Resolution:
1) There is a communication issue between the CA Mobile/Desktop client machine and the arcotAFM machine. 
2) You are trying to connect to arcotAFM on HTTPS and the CA Mobile OTP or Desktop client machine does not have the root certificate imported into the trusted certificate store of the CA Mobile OTP app or desktop client.
3) The arcotAFM URL you are using is a URL of a load balancer therefore if you are using SSL then you need to import the root certificate of load balancer and import it into the trust store of the CA Mobile OTP or Desktop client machine.