Enterprise Dashboard and Registry services are not starting

Document ID : KB000009014
Last Modified Date : 14/02/2018
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Issue:

Enterprise Dashboard and Registry services are not starting and  Customer is getting  the below errors in EnterpriseDashboard Log 

2017-12-13 16:06:51,603Z (16:06) [qtp948391605-82] ERROR org.grails.web.errors.GrailsExceptionResolver - ConverterException occurred when processing request: [GET] /locale/languages 
Unconvertable Object of class: java.util.ArrayList. Stacktrace follows: 
org.grails.web.converters.exceptions.ConverterException: Unconvertable Object of class: java.util.ArrayList 

Caused by: java.net.BindException: Address already in use 
at sun.nio.ch.Net.bind0(Native Method) 
at sun.nio.ch.Net.bind(Net.java:433) 

at org.apache.catalina.connector.Connector.startInternal(Connector.java: 986) 

...........[main] ERROR grails.boot.GrailsApp - Application startup failed 

Environment:
All Supported DevTest releases.
Cause:

There were hung DevTest processes running in the background.  When customer tried to restart the Services it would not start properly. 

Resolution:

Stop all the DevTest Components.

1. Execute the below command to make sure no processes are running

>ps -ef | grep Java 

If you still see java processes, use the  Kill -9 <PID> command  to kill the process. 

 2. Go to the /tmp or /temp folder for the Linux machine

Look to see if there is an i4jdaemon file that has EnterpriseDashboardService in the name like for example:

-rw-r--r-- 1 root root 5 Oct 23 07:38 i4jdaemon__opt_ca_lisa_DevTest_bin_EnterpriseDashboardService 

 Delete the file from this folder, you will need to be root permission to do this.

3. Delete the old lisatmp_x.x folder for clean logs.

4. Restart all the components starting with the Enterprise Dashboard.

 Do this command from your DEVTEST_HOME/bin folder to verify the status.

./EnterpriseDashboardService status

 Do the same for the Registry and the other components.