Enrolling gateway in Portal fails with TLS1.2 error

Document ID : KB000113328
Last Modified Date : 08/10/2018
Show Technical Document Details
Issue:
When trying to enroll a new API Gateway in API portal, after you have entered the enrollment url at :
Tasks -> Extensions and Add-Ons -> Enroll with Portal and press apply.
I get the following  error message: "Unable to enroll: TLSv1.2"

In the / opt / SecureSpan / Gateway / node / default / var / logs / ssg * log I only get the following error message:
2018-08-15T14: 41: 48.716 + 0200 INFO 888 com.l7tech.server.admin.AsyncAdminMethodsImpl: Asynchronous job JobId <java.lang.Boolean>: 3898f368a6c29ec6c9613d346a827e9e893cdff53c78c9c68d96a4a061cd45c3 threw an exception: TLSv1.2
Resolution:
Verify your Gateway system.properties file, when you have edited this file to enforce TLSv1.2 with the following line 
 
# Force TLS 1.2 for Node HTTPS (2124)
https.protocols=TLSv1.2

Make sure there is no hidden non printable character after the  TLSv1.2 for example a blank.
If so remove it and restart the gateway.