Endevor Web services compatibility

Document ID : KB000122481
Last Modified Date : 06/12/2018
Show Technical Document Details
Introduction:

When upgrading the Endevor Web services, you may plan to upgrade the server then the client later.

This knowledge document explains why you must keep server and client at the same level.

Question:
We are currently installing and testing Endevor R18 (V12).
Do we also need to upgrade Webservices or is V17 Webservices compatible with Endevor R18 on z/os?
Environment:
Mainframe
Distributed
Answer:

You cannot have different versions in client and server.

If you have Endevor Web Services V18, your client has to be updated also.

There have been also some updates and changes from 17.0 to 18.0 so you won't be able to use it to full extent even if you would be able to somehow start it.