EMS writing to the UIM DB failing

Document ID : KB000008565
Last Modified Date : 14/02/2018
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Issue:

testing the EMS and alarm routing the are some ems syncing problems to the UIM DB with the following getting written to the log file:

 

Aug 21 15:56:09:445 [maintenanceTimer, ems] Cancel rule: false uim_db_sync triggered by: com.ca.uim.schedule.uim_db_sync exceeded maxRunDurationForActions: 10000(msec) 

Aug 21 15:56:09:445 [maintenanceTimer, ems] Cancel rule: false uim_db_sync triggered by: com.ca.uim.schedule.uim_db_sync exceeded maxRunDurationForActions: 10000(msec) 

Aug 21 15:56:09:445 [maintenanceTimer, ems] Cancel rule: false uim_db_sync triggered by: com.ca.uim.schedule.uim_db_sync exceeded maxRunDurationForActions: 10000(msec) 

Aug 21 15:56:09:445 [maintenanceTimer, ems] Cancel rule: false uim_db_sync triggered by: com.ca.uim.schedule.uim_db_sync exceeded maxRunDurationForActions: 10000(msec) 

Aug 21 15:56:09:445 [maintenanceTimer, ems] Cancel rule: false uim_db_sync triggered by: com.ca.uim.schedule.uim_db_sync exceeded maxRunDurationForActions: 10000(msec) 

Aug 21 15:56:09:445 [maintenanceTimer, ems] Cancel rule: false uim_db_sync triggered by: com.ca.uim.schedule.uim_db_sync exceeded maxRunDurationForActions: 10000(msec) 

Environment:
EMS - 9.01 Robot - 7.91 Hub - 7.91 Data_engine - 8.50 UIM is 8.51
Cause:

In the directory list, the action_manager queue was having a large number of sds files. 

Directory of e:\Nimsoft\hub\q\action_manager 

 

26/09/2017 12:04 <DIR> . 

26/09/2017 12:04 <DIR> .. 

26/09/2017 12:04 104,857,828 16.sds 

26/09/2017 12:04 0 17.sds 

The queue was not clearing at all

 

Resolution:

backup the sds file to some other place and clear the 

e:\Nimsoft\hub\q\action_manager  directory