Email - device is not ready or could not find path errors

Document ID : KB000006224
Last Modified Date : 14/02/2018
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Issue:

When sending emails via NPC, either manually or via a scheduled email, an error is reported in the web or the NPC logs that says:

The device is not ready.

or

Could not find a part of the path _D:/netqos/portal/WebSite/CSS/default/xsl/email/email.xml_.

Cause:

This is due to a defect in NPC where the email template path is hard coded to D:\ upon installation, despite a different drive being specified during installation.

This is logged in Defect ID 26288 in NPC 6.1.158.

Resolution:

These errors can be resolved by running this command on the NPC server to update the email template path:

mysql -P 3308 netqosportal

replace into general values ('EmailTemplatePath', 'C:/netqos/portal/Website/CSS/default/xsl/email');

This inserts if the entry is not present, and updates it if present. Make sure the correct drive letter is specified in the command.

Restart the NetQoS Device Manager service for NPC.