EM (MOM) fails to complete startup while DEBUG logging shows there are active threads e.g. "[master clock] [Manager.Clock] Master harvest took 0ms"

Document ID : KB000008419
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

The MOM Enterprise Manager fails to complete startup but DEBUG logging in IntroscopeEnterpriseManager.log shows this repeated message block with active threads:

10/09/17 08:50:29.896 AM AEDT [INFO] [pool-3-thread-1] [Manager] BaselineDataManager:  clearing expired calculators: 0

10/09/17 08:50:30.032 AM AEDT [DEBUG] [Perst Baseline insertion] [Manager] Time taken to persist baselines to perst in seconds: 0

10/09/17 08:50:30.216 AM AEDT [DEBUG] [TimerBean] [Manager] Checking for hot config changes to /opt/apm/apps/Introscope/./config/IntroscopeEnterpriseManager.properties

10/09/17 08:50:40.001 AM AEDT [DEBUG] [master clock] [Manager.Clock] Total Time for harvest: 0ms

10/09/17 08:50:40.001 AM AEDT [DEBUG] [master clock] [Manager.Clock] Master harvest took 0ms

10/09/17 08:50:55.000 AM AEDT [DEBUG] [master clock] [Manager.Clock] Total Time for harvest: 0ms

10/09/17 08:50:55.001 AM AEDT [DEBUG] [master clock] [Manager.Clock] Master harvest took 0ms

10/09/17 08:51:10.000 AM AEDT [DEBUG] [master clock] [Manager.Clock] Total Time for harvest: 0ms

10/09/17 08:51:10.000 AM AEDT [DEBUG] [master clock] [Manager.Clock] Master harvest took 0ms

 

The IntroscopeEnterpriseManager.log never gets to the stage of showing:

[INFO] [main] [Manager.PostOfficeHub] Server listening for incoming default socket connections on port 5001

Environment:
APM 9.x, 10.x
Cause:

The Postgres APM Database running on a separate server was down and the IntroscopeEnterpriseManager.log was not reporting any "database inaccessible" or related messages.

Resolution:

After the Postgres APM Database Server was started/restarted the Enterprise Manager startup continued to completion.