Elements are successfully deleted, but are still visible in OneClick?

Document ID : KB000047072
Last Modified Date : 14/02/2018
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Elements are successfully deleted, but are still visible in OneClick 

Issue

eHealth confirms that elements were deleted successfully. However, OneClick continues to display the elements.  

The following error message is also seen:

DCI-Error: Error: Invocation of command 'nhiDciMerge' failed.

 

Environment

All supported eHealth versions and their associated supported Operating Systems.

   

Cause

OneClick may need to re-sync after elements are deleted.

 

Resolution

If rebooting the system or running commands nhHttpd stop and nhHttpd start does not solve the problem, then you may need to recreate the materialized views by following these steps:

For eHealth systems running on Windows,

1.    Close the OneClick GUI. 

2.    Open the eHealth server command prompt

3.    Run this command: nhScrubFsa -deletedObjectHours 0

4.    Run this command: nhiDbTasks -recreateMViews 

5.    Relaunch OneClick.

 

For eHealth systems running on Linux,

1. Close the OneClick GUI.

2. Go to your NH_HOME (command cd $NH_HOME)

3. cd to bin from NH_HOME

4. Run this command: ./nhScrubFsa -deletedObjectHours 0

5. cd to bin/sys from NH_HOME

6. Run this command: ./nhiDbTasks –recreateMViews

7. Relaunch OneClick.

  

Additional Information

TEC1591962: DCI-Error: Error: Invocation of command 'nhiDciMerge' failed.

Link to the tecdoc:

http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1591962.html

 

TEC1878245: How to locate eHealth documentation. (such as guides)

Link to the tecdoc:

http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1878245:.html