eHealth server topology has not been established

Document ID : KB000044643
Last Modified Date : 14/02/2018
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Problem:

 

On CA Spectrum OneClick home page / Click Administration and Select eHealth Configuration.
 
Try to add eHealth Topology and cannot see the Topology, the "Test" and "Save" works fine but the Current eHealth topology doesn't appear
 
 
Messages
 
Spectrum stdout.log:
eHealth server topology has not been established.  Cannot verify migration status. Waiting 1 minute.
   
    DEBUG - Ehealth Exception: General eHealth Web Service failure occurred
DEBUG - Checking eHealth Version...
DEBUG - Received null for getClusterInfo...
    Exception processing eHealth service table.
com.aprisma.spectrum.app.ehealth.common.EhealthException: ClusterException in invoke.
 
eH catalina.log:

2016-06-23 14:28:17,370 [ajp-nio-127.0.0.1-8010-exec-3] INFO  org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/eHealthServices] - - getClusterInfo exception Failed to get database connection. SQL exception: ORA-01017: invalid username/password; logon denied

com.concord.lib.jdbLib.ParameterException: Failed to get database connection. SQL exception: ORA-01017: invalid username/password; logon denied
 
eH listener.log:

23-JUN-2016 15:16:11 * (CONNECT_DATA=(SID=EHEALTH)(CID=(PROGRAM=JDBC Thin Client)(HOST=__jdbc__)(USER=EHEALTHBOX01$))) * (ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=55204)) * establish * EHEALTH * 0
 

Environment: 

 

eH 6.3.2.12
Spectrum 10.1

 

 

Cause:

 
Where you see EHEALTHBOX01$ we would expect to see the name of the %NH_USER%
 

Resolution:

 
The eHealth httpd63, eHealth Tomcat63 and eHealth63 Services were being started with “Local System” and not “.\ehealth”

Change the theses Services the "Log On as:" for eHealth user administrator (%NH_USER%)

 

Additional Information:  

 

See more regards eHealth and CA Spectrum on site: