eHealth installation failed with Error: The Oracle directory '/oracle/Oracle.11.2' does not exist.

Document ID : KB000030784
Last Modified Date : 14/02/2018
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Problem:
 
eHealth installation fails during oracle update steps with following error:
The Oracle directory '/oracle/Oracle.11.2' does not exist.
The Oracle Update was not installed.
Installer is not creating the Oracle.11.2 directory.
 
 
Environment:
 
Microsoft Windows 2008 32 bit and 64 bit.
 
 
Cause:
 
During eHealth install, when it fails to create directories, then in most cases we have noticed that admin shares are missing or the service is stopped. 
 
 
Resolution:
 
Please follow the steps mentioned below to resolve the issue:
1. Ensure all permissions are set correct and that you can create files and folders manually. If there is a permission issue, then please resolve the same.
 
2. Please check admin shares are created and not missing. In some cases, following errors are seen. Or, $Admin default share is missing.
 
C:\Users\ehealth>net share
The Server service is not started.
Is it OK to start it? (Y/N) [Y]: y
System error 1058 has occurred.
The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.
We must enable Microsoft "Server" service to resolve this issue and try again.
C:\Users\ehealth>net share
Share name   Resource                        Remark
-------------------------------------------------------------
C$           C:\                             Default share
D$           D:\                             Default share
IPC$                                         Remote IPC
ADMIN$       C:\Windows                      Remote Admin
The command completed successfully.
 
3. Begin the installation again, and it should now create appropriate folders.