eHealth Database Connection Timing out

Document ID : KB000007875
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Some short time after starting eHealth Services (nhStartDb, nhHttpd start, nhServer start) we are noticing that CPU is spiking on the server when attempting to make configuration changes. These changes don't seem to commit.  We see that nhiCfgServer is the runaway process on the server causing the issue.  When looking at system.log while this is occurring, we are seeing the following:


Internal Error nhiDbServer pgm nhiDbServer: Database error:   (ORA-02396: exceeded maximum idle time, please connect again). 

Directly after this log is the following which repeats:

Internal Error nhiDbServer pgm nhiDbServer: Database error:   (ORA-01012: not logged on).

Environment:
eHealth 6.3.2.x & 6.3.3.xAll supported Operating Systems
Cause:

IDLE_TIME is set incorrectly within the database for the users.

To check / example:

(This query showed that all usernames were set to the "DEFAULT" profile)
SQL> select username,PROFILE from dba_users;  

 

(This query showed that the default profile had an idle_time set for 15)
SQL> select resource_name,LIMIT from dba_profiles where profile='DEFAULT' and resource_name='IDLE_TIME';

Resolution:

Set IDLE_TIME back to UNLIMITED

 

###WARNING###

The below is making a direct change to the database, it is HIGHLY advised that a database save is taken before proceeding.

###WARNING###

 

To set IDLE_TIME back to UNLMITED for the DEFAULT profile:

 

SQL> ALTER PROFILE DEFAULT LIMIT IDLE_TIME UNLIMITED;

Additional Information:

A likely reason for the change:

 

https://www.stigviewer.com/stig/oracle_database_11g_instance/2016-06-15/finding/V-2552