eHealth configuration in Spectrum Web administration gets corrupted when attempting to update it.

Document ID : KB000045916
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue: 

When attempting to update the Spectrum WEB GUI -> Administration -> eHealth configuration page, it fails with the following error;

SPC-EHI-10029: Error saving to ehealth-config.xml : null.

 

Environment:  

CA Spectrum 10.x

 

Cause: 

Some eHealth servlets are being loaded by Spectrum Tomcat when it starts before their prerequisites.

 

Workaround:

1. On the Spectrum OneClick server, navigate to $SPECROOT/tomcat/webapps/spectrum/WEB-INF and open the file web.xml for editing.

2. Search for the term EHealthOverrideServlet. Its section should look like the following;  

<servlet>

<servlet-name>EHealthOverrideServlet</servlet-name>

<servlet-class>

com.aprisma.spectrum.app.ehealth.servlet.EHealthOverrideServlet

</servlet-class>

<init-param>

<param-name>name</param-name>

<param-value>eHealth Override</param-value>

</init-param>

<load-on-startup>90</load-on-startup>

</servlet>

 

3. Change the value for the <load-on-startup> parameter from 99 to 90.

4. Restart the Spectrum Tomcat server.

 

Additional Information:

The load-on-startup parameter indicates an order for servlets to be loaded by the tomcat server. Servlets with higher numbers get loaded after servlets with lower numbers. This change loads EHealthOverrideServlet before some other eHealth servlets when tomcat starts and so enables prerequisites for the integration earlier in the process stack.