EGC30N.EXE crashes while trying to queue a deployment job via the deployment wizard.

Document ID : KB000026617
Last Modified Date : 14/02/2018
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Problem:

The following error occurs while trying to queue a deployment job via the deployment wizard:

Egc30n.exe caused an EXCEPTION_ACCESS_VOILATION in module GUI_DEP.DLL at 001B:01C7DC54.
The instruction at "x10063e12" referenced memory at "0x00000000". The memory could not be "read".

 

Cause:

Issue can arise out a corrupt software package and by cleaning up the folders mentioned below it corrects the issue and deployments can continue with an error.

 

Resolution:

Manually delete the agent packages from the %sdroot%\..\packages\Public and the %sdroot%\..\packages\Private folders, except the 'dmprimer' folder from the \packages\private folder.

  1. Follow the below steps to Re-register the packages.

    **Open a Command Prompt

    **Browse to the Installation DVD root via the CMD prompt

    **Run 'dmscript.exe dsmPush.dms copy -all' to register the DSM packages with the server.
    The registration log is written in the %temp% folder namely TRC_Inst_dsmpush.xxxxxxxx.log.

    **The registration of the packages is complete when dmscript.exe no longer appears under the processes' tab of Windows Task Manager.

    **Run 'dmscript.exe dsmPush.dms check' to check whether the packages have been registered properly.
    The dsmPush.dms check log is written in the %temp% folder namely DSM_dsmPush_check_output.txt

  2. When complete, check the folders to make sure a new copy of the package has been copied to the \packages\public folder.

  3. Re-launch the DSM Explorer (shut down existing if still running) and test a new deployment.