EEM Installation Failure with RC=245

Document ID : KB000005001
Last Modified Date : 14/02/2018
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Issue:

The EEM 12.51 installation failed with RC=245. When viewing the /tmp/eiam-install.log after the failure, the following error is observed...

27 Dec 2016 13:26:40 FATAL ReadResponseFile - com.ca.eiam.installer.exception.BadResponseFileException: DSA port is not available on the machine

Environment:
EEM 12.51LINUX
Cause:

The DSA port (509) is not available on the machine. Typically this is due to some other process tying up the port.

Resolution:

Run the following command to find the running process that is using port 509...

lsof -I :509 |grep LISTEN

This will show the process name and pid for the process using port 509. This process must be stopped/killed to free up the port. Once this is done, the installation will no longer fail with the error saying the DSA port is unavailable.