EEM Installation Fails: CA Directory configuration failed

Document ID : KB000007784
Last Modified Date : 20/07/2018
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Issue:

We are getting the following error when trying to install EEM using the binary in the $CASHCOMP/eem/install directory:

 

15 Aug 2017 18:53:18 INFO  DXServer - Command [dxnewdb itechpoz] exit code [0]

15 Aug 2017 18:53:18 INFO  DXConfigEditor - Configuring the access file

15 Aug 2017 18:53:18 INFO  DXConfigEditor - ----------------------------------------------------

15 Aug 2017 18:53:18 INFO  DXConfigEditor - /opt/CA/Directory/dxserver/config/access/itechpoz.dxc

15 Aug 2017 18:53:18 INFO  FilePermission - 

15 Aug 2017 18:53:18 INFO  FilePermission - 

15 Aug 2017 18:53:18 INFO  FilePermission - 

15 Aug 2017 18:53:18 INFO  DXServer - Starting dxserver services

15 Aug 2017 18:53:18 INFO  DXServer - ----------------------------------------------------

15 Aug 2017 18:53:20 INFO  DXServer - itechpoz starting

..

itechpoz failed to start

Starting all dxservers

 

15 Aug 2017 18:53:20 INFO  DXServer - Command [dxserver start all] exit code [0]

15 Aug 2017 18:53:20 INFO  DXServer - Modifying DSA contents

15 Aug 2017 18:53:20 INFO  DXServer - ----------------------------------------------------

15 Aug 2017 18:53:21 INFO  DXServer - ldap_bind: Can't contact LDAP server (-1)

 

15 Aug 2017 18:53:21 INFO  DXServer - Command [dxmodify -a -c -H ldap://localhost:509 -f "/tmp/320849.tmp/setup/cadir/itechpoz.ldif"] exit code [1]

15 Aug 2017 18:53:21 ERROR DXServer - Command [dxmodify -a -c -H ldap://localhost:509 -f "/tmp/320849.tmp/setup/cadir/itechpoz.ldif"] failed with error code [1]

15 Aug 2017 18:53:21 FATAL ConfigureCADirectoryAction - CA Directory configuration failed

java.io.IOException: Command [dxmodify -a -c -H ldap://localhost:509 -f "/tmp/320849.tmp/setup/cadir/itechpoz.ldif"] failed with error code [1]

at com.ca.eiam.common.dsa.DXServer.runDxTools(DXServer.java:295)

at com.ca.eiam.common.dsa.DXServer.modify(DXServer.java:259)

at com.ca.eiam.installer.customcodeaction.ConfigureCADirectoryAction.install(ConfigureCADirectoryAction.java:162)

at com.zerog.ia.installer.actions.CustomAction.installSelf(Unknown Source)

at com.zerog.ia.installer.InstallablePiece.install(Unknown Source)

at com.zerog.ia.installer.InstallablePiece.install(Unknown Source)

at com.zerog.ia.installer.InstallablePiece.install(Unknown Source)

at com.zerog.ia.installer.GhostDirectory.install(Unknown Source)

at com.zerog.ia.installer.InstallablePiece.install(Unknown Source)

at com.zerog.ia.installer.Installer.install(Unknown Source)

at com.zerog.ia.installer.LifeCycleManager.consoleInstallMain(Unknown Source)

at com.zerog.ia.installer.LifeCycleManager.executeApplication(Unknown Source)

at com.zerog.ia.installer.Main.main(Unknown Source)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.zerog.lax.LAX.launch(Unknown Source)

at com.zerog.lax.LAX.main(Unknown Source)

Environment:
CA Embedded Entitlements Manage r12.51 CR01/CR02/CR03/CR04/CR05 on Linux
Cause:

When the install fails on start the dxserver service after it creates the service and database, then there is an inheritance permissions issue.

Resolution:

1. Clean up the failed EEM installation

a. Delete the EmbeddedEntitlementsManager directory (located in the /opt/CA/SharedComponents directory)

b. Delete the Directory directory (locate din the /opt/CA directory)

c. If applicable, delete the CADirectory directory(located in the /opt/CA/SharedComponents directory)

2. Start a new session 

3. Navigate to the $CASHCOMP/eem/install directory

4. Confirm that you are the user 'root'

5. Temporarily, change shells so that you are using the C Shell (csh)

6. Run the EEMServer_*_linux.bin interactively or use the eem.properties file to install EEM silently