EEM Can't Start Igatway fails to start

Document ID : KB000113422
Last Modified Date : 20/09/2018
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Issue:
Igateway service does not start

User-added image
Environment:
Service Operations Insight 4.2
Embedded entitlements Manager 8.4
Cause:
We enabled debug in igateway by changing the logging.properties files to TRACE

igateway.log
[132092] 09/10/18 04:05:20 DEBUG :: SSLContextConfigurator::configureSSLContext : mode is empty and FIPS is OFF using SSLV23
[132092] 09/10/18 04:05:20 DEBUG :: SSLContextConfigurator::configureSSLContext : SSLContext configured successfully
[132092] 09/10/18 04:05:20 DEBUG :: AsyncTCPConnAcceptor::start : setting maxconnections to [ 100 ] for connection listening on port [ 0 ]
[132092] 09/10/18 04:05:20 ERROR :: AsyncTCPConnAcceptor::start : unable to bind to port [ 0 , errno : 10055 ]
[132092] 09/10/18 04:05:20 ERROR :: AsyncTCPListener::startConnectors : connector for port [ 0 ] failed to start and mustlisten set to true
[132092] 09/10/18 04:05:20 ERROR :: AsyncTCPListener::start : unable to start connector/s

The netstat output shows that there are 136 ports shown ESTABLISHED

The problem is that the system is not able to allocate the a random port to EEM. Hence EEM is not able to start.
Resolution:
Restarting the server helped in closing the ports which were held in established status. Hence the EEM server is able to start successfully