Duplicate usernames in Flowdock

Document ID : KB000047773
Last Modified Date : 14/02/2018
Show Technical Document Details

Summary

In the past, usernames were not unique in Flowdock so you could have two @melissa usernames. Now usernames must be unique but no usernames were changed when the restriction was put into place. Usernames should be updated to be unique.

Issue

We have 2 Melissas in Flowdock?and Flowdock is primarily using one and overriding the other.

When using?an @mention, i.e. @melissa,?melissa1@company.com?is used even when we select?melissa2@differentcompany.com. ?

This is causing confusion.

Cause

Flowdock?does not support having users with the same username in the same organization anymore. ?When someone types a message with a username that's used by multiple people, we have no way of knowing which user is being referenced. ?When?this change was made, we didn't want to modify existing usernames, which is why both Melissas see a warning dialog (that encourages them to change their username to something unique) whenever they open a flow that they're both in.

Resolution

To resolve the issue, one or both of the users will need to change their username so that it's unique. ?We have three users name "Ville"?on the Flowdock team, so this is something that we've had to deal with as well.