Duplicate object search results after using client copy

Document ID : KB000117061
Last Modified Date : 05/10/2018
Show Technical Document Details
Issue:
Whenever Client Copy is ran, then duplicates of the objects copied are showing up in Object Search. Multiple blank lines display after the object in Advanced Search. This occurs when a client is deleted and created again through Client Copy. 

Clicking on one of the duplicates in Object Search results in the following error:

Error during XRequest com.uc4.webui.communication.requests.GetObjectPropertiesAdapter: could not find the object. It may have been deleted or renamed.

Object Search (where all 5 workflows have the same name):
User-added image

Advanced Search:
User-added image
Cause:
This is a bug with the Client Copy utility. 
Resolution:
This issue is fixed in the following versions:

Automation Engine 12.2.1 – planned release date for October 23, 2018
Automation Engine 12.3.0 – planned release date for February 28, 2019

Workaround:
Deleting and rebuilding the JWP index cache will get rid of all current duplicates; however, running the client copy afterwards will create duplicates again.