DUAS5: Could not load program/module when launching uxstr

Document ID : KB000086645
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Affects Release version(s): 5

Error Message :
==============================================
Execution SAP JOB: JOB_NAME
Could not load program /orsyp/UNIV50/exec/uxstr:
Could not load module /usr/lib/libux_v533/libuxft.so.
Dependent module /lib/libssh2.a(libssh2.so.1) could not be loaded.
Member libssh2.so.1 is not found in archive
Could not load module uxstr.
Dependent module /usr/lib/libux_v533/libuxft.so could not be loaded.
Could not load module .
=======================================

Patch level detected:Dollar Universe 5.3
Product Version: Dollar.Universe 5.3.3 FX25002 or 5.6.0 FX25010

Description:
Suddenly, SAP jobs abort with the above error related to missing libraries.
Environment:
OS: All Linux/Unix
Cause:
Cause type:
Configuration
Root Cause: The libraries symbolic link /usr/lib/libux_v533/ or /usr/lib/libux_v560 is not pointing to the correct folder
Resolution:
Create or update the symbolic link pointing to the node's exec/lib folder.

Examples:

lrwxrwxrwx    1 root     system           22 Mar  3 2016  /usr/lib/libux_v560 -> /COMPANY_560_folder/exec/lib
lrwxrwxrwx    1 root     system           31 Aug 28 12:00 /usr/lib/libux_v533 -> /COMPANY_533_folder/exec/lib

 

Fix Status: No Fix

Additional Information:
Workaround :
N/A