"DUA has refused our request (413: Request Entity Too Large)" error message

Document ID : KB000086270
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
On the universe.log or the IO_<datestamp>.dump.log:

################
|ERROR|X|IO |pid=5168.12148| _read_dua_response | DUA has refused our request (413: Request Entity Too Large)
################

On the Dollar Universe Explorer,on the application.log and unistartdux.log: 

################
[debug] play - Invalid Json 
com.fasterxml.jackson.core.JsonParseException: Unexpected end-of-input: expected close marker for OBJECT (from [Source: [B@4e7142; line: 1, column: 101937]) 
at [Source: [B@4e7142; line: 1, column: 204801] 
... 
[debug] play - Invalid Json 
com.fasterxml.jackson.core.JsonParseException: Unexpected end-of-input: expected close marker for ARRAY (from [Source: [B@1f5dc4b; line: 1, column: 0]) 
at [Source: [B@1f5dc4b; line: 1, column: 204801]
################

Patch level detected:Dollar Universe 6.4.00
Product Version: Dollar.Universe 6.4.01

Description :In case you have defined a Dollar Universe Explorer on the UVMS where the node $U is registered, the node will try to send the job statistics every two minutes to Dollar Universe Explorer.
In case there is a file DATE_job on the folder data/area with an important size, it is likely that the following error appear every two minutes on the universe.log:

################
|ERROR|X|IO |pid=5168.12148| _read_dua_response | DUA has refused our request (413: Request Entity Too Large)
################
Environment:
OS: All
Cause:
Cause type:
Defect
Root Cause: This issue stems from a limitation of 5MB on the size of the json file sent by Dollar Universe to Dollar Universe Explorer in affected versions.
In case the file $UXDEX/_job is larger than 5MB, the Dollar Universe will display the above error in the logs.
Resolution:
Upgrading Dollar Universe to version 6.5.21 will correct this problem. If upgrading to Dollar Universe version 6.5.21 is not immediately possible, the following workaround can be applied:
The node should be stopped and all files in '$UXDEX/_job' should be moved to a different location. Once this is done, the node should be restarted. This should be sufficient to solve the issue, until the data grows larger than 5MB again.

Fix Status: Released

Fix Version(s):
Component: Application.Server
Version: Dollar.Universe 6.5.21
Additional Information:
Workaround :
N/A